/
Rename HandleEvent to triggerEvent
Rename HandleEvent to triggerEvent
Right now method HandleEvent
exists in 2 classes:
kApplication
kEventManager
kEventHandler
These methods call each other in same order as listed above. However only kEventHandler
can actually handle event, but others two (kApplication
and kEventManager
) only are triggering/throwing/emitting event out there to be processed.
To make things clearer to understand for new (and existing) developers I propose to rename HandleEvent
method in kApplication
and kEventManager
classes to one of following:
triggerEvent
- jQuery-styleemit
Event
- Java-stylethrowEvent
- PHP-style, but might not the the right name, because we usually throwing an Exceptions in PHP